Hyperloop Requirements

Requirements

You’ll need to have the following installed on your machine as the recommended requirements to use Hyperloop 3.0.0+:

  • Appcelerator Studio: 5.0.0+
  • Titanium SDK: 7.0.0+
  • Appcelerator CLI: 7.0.0+
  • Android 4.0.0+ (for Android development)

You can install Appcelerator Studio and Appcelerator CLI to get the latest version of all these components.

Optional Dependencies

These dependencies are used only if you plan to integrate hyperloop with them. You do not need Alloy or Cocoapods to use Hyperloop, but may use Hyperloop in an Alloy app - or consume 3rd-party libraries on iOS using Cocoapods.

Note: If you plan on using CocoaPods as a third-party dependencies manager, you will need to have (at a minimum) CocoaPods 1.0.0 or later installed. See Using third-party libraries with CocoaPods for details on how to install and set up your project.

Installation

Appcelerator Studio

To download and install Appcelerator Studio:

  1. Log in to https://platform.axway.com/.
  2. Expand the Appcelerator menu  and click on App Builder Studio.
  3. Download the installer or ZIP file for your operating system.
  4. Launch the downloaded installer


Please ask your Confluence administrator to update the license for the MultiExcerpt Plugin for Confluence 4+ .
Admin Info: The error is: license VERSION_MISMATCH

Titanium SDK

Titanium SDK is included in the installation of Appcelerator Studio.

Appcelerator CLI

Refer to Setting up the Appcelerator CLI for instructions and preparation for installing Appcelerator CLI.

Alloy Framework

The Alloy command-line interface and plugin will be automatically installed by Appcelerator Studio or the Appcelerator CLI.

Related Links