Troubleshooting

If for any reason you need to contact Axway Support, you should provide the product name and version number as well as information about your environment.

Check the version number of EBICS Client

In the EBICS Client GUI, click your user name in the top-right corner of the page and select About.

The product name and version number are displayed.

Consult logs

To access the log files, go to:

  • <EBICS Client install dir>/data/log/ebicsclt-edge.log
  • <EBICS Client install dir>/data/log/ebicsclt-model.log
  • <EBICS Client install dir>/data/log/ebicsclt-ui.log

Configure log levels

You can set the log levels according to the log messages you want to receive.

The following levels are available:

  • TRACE
  • DEBUG
  • INFO
  • WARN
  • ERROR
  • FATAL
  • OFF

Modify log levels as follows:

  1. Edit the following properties in the <EBICS Client install dir>/data/conf/application.properties file.
  2. Replace INFO with the required level:

    #Log level for backend services
    model.logging.level.root=INFO

    #Log level for GUI services
    ui.logging.level.root=INFO

    #Log level for proxy services
    edge.logging.level.root=INFO

Regenerate internal EBICS Client certificates

After some time (usually several years), the internal EBICS Client TLS certificates will expire, and no longer be valid.  In this case you must generate new certificates.

Use the Generate certificates option available in the Configuration tool to regenerate certificates. For details, see Keystore and Truststore Configuration.

Activate EBICS traces

In some cases it might be useful to activate EBICS traces.  For performance reasons, you should only activate EBICS traces if they are really required, for example if requested by Axway Support.

To activate EBICS traces, select the EBICS Trace Enabled option in the Contract Details screen.  Alternatively, you can activate the option by modifying a contract.

The directory used for storing files is specified during configuration in the Product Customization screen, EBICS traces directory path field.  For details, see Use the EBICS Client Configuration tool.

The files are stored according to HOSTID_CUSTOMERID and the date. 

Cannot access Swagger UI

If you cannot access the Swagger UI (for API documentation), make sure that:

  1. You are using TLS for the communication between EBICS Client and Keycloak.  Otherwise the authorization might fail depending on whether or not the browser allows mixed content (HTTP and HTTPS).
  2. In your browser, you trust both the certificate of the edge and of the model services (or another certificate higher up in the chain of certificates).

Cannot start EBICS Client - Oracle database errors

Problem: EBICS Client does not start and you have Oracle database errors indicating that some tables have not been found.

Cause: EBICS Client has failed to start during the initialization of the database. This behavior is because of Flyway, which detects tables inside the recycle bin of the user if not purged, and then considers that the database already exists (even if the only data is in the recycle bin) and does not create any table.

Solution:  Empty the Oracle recycle bin.  Make sure that the Oracle user defined for EBICS Client is totally empty (i.e. no tables exist and the recycle bin is empty).

Cannot start EBICS Client - MySQL timezone error

Problem:

It can happen that the default timezone is not properly configured in MySQL Server 5.x.

In this case you will find the following error in the logs (Configuration tool or Model):

Invocation of init method failed; nested exception is liquibase.exception.DatabaseException: java.sql.SQLException: The server time zone value 'CEST' is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specific time zone value if you want to use time zone support.

Cause:

The operating system is using a timezone that MySQL Server does not recognize.

Solution:

You need to update the list of timezones by adding them to the "mysql" database, and set a default timezone that is part of this list.  Ask your MySQL Administrator to issue the following commands in the order given below:

If MySQL Server is hosted on a Windows machine:

If MySQL Server is hosted on a UNIX machine:

  • Launch:  mysql_tzinfo_to_sql /usr/share/zoneinfo 2>/dev/null  > timezone_posix.sql

For Windows and UNIX:

  1. Launch:  mysql -u root -p mysql < FolderForFile\timezone_posix.sql
    You will be prompted to enter the password of the root user.
  2. Edit the MYSQL INI file within [mysqld] paragraph:
    • default-time-zone='Europe/Paris'
    • Replace the value with any time zone suiting your needs and that is defined within the mysql.time_zone_name table.
  3. Restart the MySQL server.
  4. You can delete the temporary timezone_posix.sql file (and zip file on Windows).

For more information, go to:

https://dev.mysql.com/doc/refman/5.6/en/time-zone-support.html#time-zone-installation


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