Supported platforms and software

This section describes the various supported platforms and Axway software, as well as third-party software, when using Central Governance. Information includes:

Operating systems

You can run Central Governance on the following operating systems:

Operating systems

Microsoft Windows Server

2008 R2

x86-64

2012

x86-64

2012 R2

x86-64

2016

x86-64

Red Hat Enterprise Linux

5

x86-64

6

x86-64

7

x86-64

8 x86-64

Oracle Linux

5

x86-64

6

x86-64

7

x86-64

SUSE Linux Enterprise Server

11.2

x86-64

12

x86-64

CentOS 6, 7, 8  
Note Clustering is supported only on Linux. Both nodes in an active-passive cluster must run on a computer that uses a supported version of Red Hat Enterprise Linux.

Databases

PassPort in Central Governance and external Sentinel

Central Governance 1.1.3 supports an external Sentinel version 4.2.0 SP13 or higher.

Database Version Central Governance

Oracle DBMS

11.2

1.1.3

12.1

1.1.3

12.2

1.1.3

19c 1.1.3 SP14 and higher   

Oracle RAC

11.2

1.1.3

19.3 1.1.3 SP17 and higher

Microsoft SQL Server

2012

1.1.3

2014

1.1.3

2016

1.1.3 SP1 and higher

2017 1.1.3 SP17 and higher

MySQL

5.7

1.1.3

Note If you use Central Governance with MySQL, you should not upgrade to SP18. Please refer to the Central Governance 1.1.3 SP18 Readme for details.
Note Central Governance does not support using Sentinel with an external DB2 database.

MongoDB

Central Governance

MongoDB

Comment

1.1.3 SP5 to SP8

3.2

You can install Central Governance with an external MongoDB.

1.1.3 SP9 and higher 3.2.9 Updated the internal MongoDB version.
1.1.3 SP10 3.4 Updated the external MongoDB version.
1.1.3 SP14 3.6.17 Updated the internal MongoDB version.

Browsers

Central Governance supports the following web browsers for navigating the user interface and help. Although all of these are supported, tests have indicated the UI performs best in Chrome.

Client OS Browser Browser version
Windows 7 - 32 and 64 bit Internet Explorer * See Note 11
Windows 7 - 32 and 64 bit Chrome Latest
Windows 7 - 32 and 64 bit Firefox Latest
Windows 7 - 32 and 64 bit Firefox Extended Support Release (ESR) Latest
Windows 8.1 - 64 bit Internet Explorer * See Note 11
Windows 8.1 - 64 bit Chrome Latest
Windows 8.1 - 64 bit Firefox Latest
Windows 8.1 - 64 bit Firefox Extended Support Release (ESR) Latest
Windows 10 - 64 bit Edge Latest
Windows 10 - 64 bit Internet Explorer * See Note 11

Browsers must support the following:

  • Browsers must accept cookies from the Central Governance user interface.
  • On any supported version of Internet Explorer disable compatibility view if you encounter display issues while using the help.
  • Local storage must be activated in all supported browsers. It is active in all browsers by default, but the following is how to verify:
    • In Chrome, go to Settings | Show advanced settings | Privacy | Content settings | Cookies. Make sure the following is not selected: Block sites from setting any data.
    • In Firefox, enter the address about:config and click I'll be careful, I promise if prompted. Scroll down to dom.storage.enabled and make sure the value is true.
    • In Internet Explorer, go to Tools | Internet options | Advanced. Under Settings | Security, make sure the following is selected: Enable DOM storage.
  • Central Governance has an HTML5-enabled user interface. The JavaScript option must be activated on your browser:
    • In Chrome, go to Settings | Show advanced settings | Privacy | Content settings | JavaScript. Make sure the following is selected: Allow all sites to run JavaScript.
    • In Firefox, go to Tools | Options. Make sure the following are selected: Block pop-up windows, Load images automatically, and Enable JavaScript.
    • In Internet Explorer, go to Tools | Internet options | Security | Security level for this zone. Under Settings | Scripting, make sure the following is selected: Enable scripting of Java Applets.

Note:The Central Governance log in page uses window.localStorage for persistent data on the hard disk. If the browser's security does not allow accessing the hard disk, you cannot log on Central Governance using that browser.

For Internet Explorer 11 on Windows 7 or 8.1

  1. Use the default security settings to mitigate this issue on Windows versions other than Windows 10:
  2. Click on the Tools menu, then Internet Options.
  3. Select Security > Trusted sites and click Reset all zones to default level.
  4. Click Apply.
  5. Restart Internet Explorer.

For Internet Explorer 11 on Windows 10

  1. From a command window, enter the following command to enable windows.localStorage:
  2. icacls %userprofile%\Appdata\LocalLow /t /setintegritylevel (OI)(CI)L
  3. Press Enter.
  4. Restart Internet Explorer.

Swagger

As of Central Governance 1.1.3 SP11, REST API usage is based on Swagger 3.0. For more information, you can visit swagger.io.

File exchange software

Central Governance can manage Transfer CFT and SecureTransport after the products are registered on Central Governance.

Transfer CFT

Amplify Transfer CFT is an enterprise-ready, multi-platform file and message transfer controller designed for very large deployments.

Transfer CFT operating systems

Central Governance supports Transfer CFT on the following operating systems.

Operating System Former OS names

Unix

N/A

Windows

N/A

IBM i

OS/400

z/OS

MVS

HP NonStop N/A
Note Central Governance does not support managing Transfer CFT that run on OpenVMS systems.

SecureTransport

Amplify SecureTransport is a Managed File Transfer (MFT) product that enables users to securely manage and track file transfers in support of critical business processes and ad hoc human transactions.

MFT products

Software

Version

Central Governance

Certification details

Transfer CFT

3.1.3, 3.2.4, 3.3.2

1.1.3

PeSIT

3.4 P1, 3.5, 3.6 1.13 SFTP

SecureTransport

5.3.6, 5.4, 5.5

1.1.3

FTP(S), SSH, HTTP(S), PeSIT

cURL

7.58.0

1.1.3

FTP(S), HTTP(S)

FileZilla Client

3.31.0

1.1.3

FTP(S), SSH

WinSCP

5.13

1.1.3

SSH

Samba

3.6.6

1.1.3 SP6

SMBv2 (Using the SMB Connector, available at  AMPLIFY Repository)

MS Windows Server 2012 R2

6.3.9600

1.1.3 SP6

SMBv2 (Using the SMB Connector, available at  AMPLIFY Repository)

LDAP

Central Governance works with LDAP server implementations that were generated in compliance with:

  • RFC 1777 - LDAP v2
  • RFC 2251 - LDAP v3

Business activity monitoring

Central Governance supports the following certified software for Business Activity Monitoring.

Software

Version

Axway Sentinel

4.2.0 SP13 and higher

SMTP

You can configure Central Governance with a SMTP server to send notification messages when a user is created, and configure Sentinel with a SMTP server to send alert messages.

Central Governance and Sentinel work with any RFC 5321 compliant SMTP server.

Certified SMTP server software

Version

OpenSMTPD

6.0.3

PGP

SecureTransport should work with PGP keys that are generated in compliance with RFC 4880.

PGP Software

Version

GnuPG

2.2.4

SecureTransport connectors

Central Governance supports the following SecureTransport connectors:

Connector SecureTransport

version

Connector

version

Downloads
S3

5.3.6

5.4

5.5

1.0

1.5

 

 AMPLIFY Repository > S3 connector

SMB

5.3.6

5.4

5.5

1.0

1.2

 AMPLIFY Repository > SMB
Syncplicity

5.3.6

5.4

5.5

1.0

1.5

 AMPLIFY Repository > Syncplicity
Azure Blob

5.4 Patch 6 and higher

5.5

1.3 AMPLIFY Repository > Azure Blob Storage Connector

Other third-party and open source software

You can access additional third-party information at Central Governance 1.1.3 Third Party Licenses (login required).

 

 

Central Governance | Document Directory

Related Links