Upgrade Interchange to version 5.10.1 or later

Before you can upgrade from Interchange to B2Bi, you must first make sure that your current Interchange installation is at least version 5.10.1. This topic describes how to accomplish this upgrade.

Prepare the Interchange upgrade

Back up your current implementation before performing an upgrade to ensure if part of the upgrade fails, you can revert back to a working system, or retrieve information about community and partner configurations, private certificates, and so on.

General advice for preparing an Interchange upgrade:

  • Backup the community (if migrating from Interchange 5.7 or above)
  • Back up all custom components and other customizations
  • Backup all private certificates
  • Stop Interchange
  • Backup the database
  • Backup the common folder and the installation folder

Are you changing host machines?

Normally, an Interchange upgrade is between two product versions on a single host computer. If your upgrade target destination is on a different computer, see Upgrade Interchange between two hosts.

Interchange-to-Interchange upgrade example 1

The upgrade from an older version of Interchange to version 5.10.1 or later version consists of a number of steps. A generic example of the process in is provided below.

For additional details of upgrading from one Interchange version to another, see the Interchange Installation Guide.

Before you begin:

Perform the upgrade preparation steps as described in the Interchange Installation Guide.

Procedure:

  1. Stop the trading engine node.
  2. Go to <Interchange_install_directory>/Interchange/conf/ and open filereg.xml. Note the location of the older installation common folder. You will need to provide this information in the Interchange installer to specify the location of the share and common folders.
  3. See Note on Interchange shared paths.
  4. Uninstall the previous version of Interchange. After uninstalling, check the installation directories. You can see that the .../Interchange folder is still present, and that it contains installer-related items in it. Additionally, the shared directory contains the common folder. You can now delete these folders and their content.
  5. Log out of your operating system and log on again.
  6. Install Interchange 5.10.1 or later. Make sure that you have met the prerequisites for this installation. See the Interchange Installation Guide / Interchange prerequisites chapter.
  7. When prompted by the installer, enter a valid shared path. For example, you can use the common folder location that you noted in step 2 of this procedure.
  8. See Note on Interchange shared paths.
  9. Restore all custom components and other customizations:
    • Custom components and customizations
    • Runtime data
  10. Start Interchange.
  11. Validate the configuration.
  12. Continue with the post-upgrade steps. See the Interchange Installation Guide / Post-upgrade steps chapter.

Interchange-to-Interchange upgrade example 2

In some cases it is not possible to upgrade from the current deployed version directly to version 5.10.1 or later. Intermediate steps may be required.

The following example illustrates an upgrade from Interchange 5.7.1 to Interchange 5.12.0. In this case, intermediate upgrades to 5.9.0 and 5.10.1 are necessary. Depending on your implementation version, not all of the steps described for upgrades have to be followed for each intermediary step.

For additional details of upgrading from one Interchange version to another, see the Interchange Installation Guide.

Before you begin:

Perform the upgrade preparation steps as described in the Interchange Installation Guide.

Procedure:

  1. Stop the trading engine node.
  2. Stop Interchange.
  3. Install the latest SP for Interchange 5.7.1.
  4. Start/stop Interchange to trigger the database upgrade.
  5. Uninstall Interchange 5.7.1 prior to the installation of the new version.
  6. Install Interchange 5.10.1 including the latest SP.
  7. Start/stop Interchange to trigger the database upgrade.
  8. Uninstall Interchange 5.10.1 prior to the installation of the new version.
  9. Install Interchange 5.12.0 and the latest SP.
  10. Restore all custom components and other customizations.
  11. Start Interchange to trigger the database upgrade.
  12. If you are upgrading a cluster of multiple nodes, you can now upgrade the other nodes, using the following procedure on each node:
    1. Perform the upgrade preparation steps as described in the Interchange Installation Guide.
    2. Uninstall Interchange 5.7.1 prior to the installation of the new version.
    3. Install Interchange 5.12.0 and the latest SP (there is no need for intermediate steps).
    4. Restore all custom components and other customizations.
    5. Start Interchange.
  13. Validate the configuration.
  14. Continue with the post-upgrade steps. See the Interchange Installation Guide / Post-upgrade steps chapter.
  15. After the validation is complete, restart the trading engines.

Note on Interchange shared paths

Previously, during Interchange installation, the installer prompted you for the common directory path, and supplied a suggested path that included the "/common" directory. For example:

/opt/axway/Interchange/common

Currently, when you do a fresh install of Interchange 5.12.0, the installer prompts you for the "common directory location". This location is different compared to the Interchange path in earlier versions. The default location of the Interchange 5.12.0 "common directory" is:

/opt/axway/Interchange/shared

It is important that for Interchange 5.12, you specify the "shared" directory location without the "/common" directory included in the path.

Related Links