Appcelerator CLI 6.0.0.Beta Release Note

Appcelerator CLI 6.0.0.Beta - 18 October 2016

Appcelerator CLI 6.0.0.Beta is a patch release that includes several improvements and bug fixes.

Component versions

The following components are shipped with CLI 6.0.0.Beta:

Alloy 1.9.3
Arrow Builder 1.8.9
Arrow Cloud CLI 1.2.1
Titanium CLI 5.0.10

Improvements

  • CLI-1035 - Update appc-app-preview-cli-hook to latest version
    • Improved logging message for appc-app-preview-cli-hook
  • CLI-1046 - Getting the correct module versions from dashboard
    • The CLI pulls SDK compatible module versions

  • CLI-1106 - Improve speed of extracting modules on Windows
    • Decreased extraction time for Windows modules
  • CLI-1115 - Set Node 4.x as minimum supported version
    • Set Node 4.X as the minimum supported version

Fixed issues

  • CLI-1002 - If you pass "--help" or "-h" flag to "appc ti", then "Cannot read property 'match' of undefined" error is returned
  • CLI-1003 - If you run "appc setup" with the help flag, then "appc setup" will try to find/download the latest core first
  • CLI-1024 - ti info returned the invalid json output
  • CLI-1044 - CLI 5.4.0-31 can not create apps in EU region
  • CLI-1054 - Set connection timeout for appc use command
  • CLI-1071 - Building with an invalidated session does not prompt for login and throws error
  • CLI-1077 - CLI outputting non-JSON warning to Studio
  • CLI-1081 - Modules update failed with Error: Invalid URI
  • CLI-1090 - update-notifier still getting installed
  • CLI-1092 - Error 'Cannot read property 'replace' of undefined' when creating an app without Test in an enterprise org
  • CLI-1099 - appc login error when specify arrowcloud url without protocol
  • CLI-1122 - Hyperloop is downloaded every time lastUpdateCheckTiDownloads expires on Windows

Related Links