API Builder FAQ

This document provides references to answer several API Builder frequently asked questions (FAQs).

How do I obtain support?

Contact the API Builder Axway Community to obtain support for API Builder.

How do I submit a bug?

Refer to Reporting Bugs or Requesting Features for more information.

Which versions of NPM and Node.js should I use?

You should have NPM (recommended minimum v6.13), and Node.js (recommended minimum v12.16 LTS) installed.

API Builder v4 maintains compatibility with a minimum of Node.js v8.9, however, using a version older than v12.16 is not recommended. See the Node.js support policy for more information.

I get errors during npm install saying I need python installed!

This can happen when installing API Builder and plugins using npm and is a warning which can be safely ignored. To bypass the warning, you can run npm install with the following flag:

npm install --no-optional

How do I setup API Builder CLI?

Refer to the Getting started section of API Builder Getting Started Guide for more information.

How do I create and run an API Builder project?

Refer to the Getting started section of API Builder Getting Started Guide for more information.

How do I configure access to the API Builder Admin console?

Refer to the Configuration section of API Builder Console for more information.

How do I create a model using the API Builder Admin console?

Refer to the Create a new model section of API Builder Getting Started Guide and the API Builder tabs section of API Builder Console for more information.

How do I create API endpoints?

Refer to API Builder APIs for more information.

How do I configure API Builder?

Refer to Project Configuration for more information.

How do I create API Builder connectors?

Refer to API Builder Connectors for more information.

How do I make a Docker container?

Refer to Dockerize an API Builder Service for more information.

Related Links