CA SiteMinder filters

The following filters enable you to integrate with CA SiteMinder:

Prerequisites

Integration with CA SiteMinder requires CA SiteMinder SDK version 12.52-sp02 or later. You must add the required third-party binaries to your API Gateway installation.

  1. Ensure that any SiteMinder binaries you may have previously added to API Gateway have been deleted.
  2. Install CA SiteMinder SDK.
  3. Copy the following jar files from the java directory of the CA SDK :
    • cryptoj.jar
    • smagentapi.jar
    • smjavasdk2.jar
  4. Add the files to the following directory on API Gateway:
  5. INSTALL_DIR/apigateway/<platform>/lib
  6. Restart API Gateway.

Related Links