What you need before you start

Your system must meet the following prerequisites before you can run the scripts to build and deploy API Gateway in Docker containers.

  • You must have the following installed on your local system:
    • Docker (see Docker requirements for supported versions)
    • Python version 2.7.x.
    • OpenSSL version 1.1 or later.
  • You must download the following from Axway Support at https://support.axway.com:
    • API Gateway UNIX/Linux installer
    • Docker scripts package
  • You must have the appropriate API Gateway licenses. Specific licenses are required for running:
    • API Gateway container
    • Admin Node Manager or API Gateway container in FIPS mode
    • API Manager enabled API Gateway container
    • API Gateway Analytics container

Docker requirements

The following versions of Docker are supported:

  • Docker CE version 17.09 or later on CentOS
  • Docker EE version 17.06 or later on RHEL

Axway supports Red Hat Enterprise Linux 7 (recommended) and CentOS Linux version 7 as the base image for Docker containers, and supports deployment on any host operating system or cloud provider supported by your Docker version.

For more information on Docker system requirements, go to Install Docker.

Related Links