Java usage and other requirements

Axway provides the correct JRE which is installed during the product installation in the directory, <installation_root_directory>/Java/<platform name>.

HP-UX 11i OS

The installer is packaged with an embedded JRE 6. For the JRE to run properly on a HP-UX 11i operating system, you need to apply a linker patch to fix the problem loading libjli.sl.

The following patches are required:

  • HP-UX 11i v1 (11.11) PA-RISC systems: PHSS_35385
  • HP-UX 11i v2 (11.23) PA-RISC systems: PHSS_37201
  • HP-UX 11i v3 (11.31) PA-RISC systems: PHSS_37202

If you do not apply the patch you will get an error message when you start the Installer. Check that the AxwayInstaller# directory is deleted in the temp directory.

Composer Client

When installing an AI Suite 2.4 project, we recommend you install the Composer Service Pack 23 minimum.

The Composer client has specific java requirements due to the usage of Java Web Start on the client computer. It requires a JRE8 to run the Composer client since jars are built with java 8. Otherwise, error messages are displayed.

Note   To run AI Enabler, you need a 32Bit JRE8.

Related Links