Java usage and other requirements

Axway provides the correct JRE which is installed during the product installation in the directory, <installation_root_directory>/Java/<platform name>.

HP-UX 11i OS

The installer is packaged with an embedded JRE 6. For the JRE to run properly on a HP-UX 11i operating system, you need to apply a linker patch to fix the problem loading libjli.sl.

The following patches are required:

  • HP-UX 11i v1 (11.11) PA-RISC systems: PHSS_35385
  • HP-UX 11i v2 (11.23) PA-RISC systems: PHSS_37201
  • HP-UX 11i v3 (11.31) PA-RISC systems: PHSS_37202

If you do not apply the patch you will get an error message when you start the Installer. Check that the AxwayInstaller# directory is deleted in the temp directory.

Composer Client

The Composer client has specific java requirements. It requires JWS version 1.6.0.x or greater, included in the JRE available on the installation kit.

If JRE 1.6.0.x or greater is not installed or is not defined as the default to be used, an error message appears when the Composer client is started.

If several versions of Java are installed on the same machine, you must tell Java Web Start which version to use by default. To do this:

  1. Open the Java configuration panel via the Windows configuration panel.
  2. Click the Java tab.
  3. Click Display in the Java Runtime application parameters window.
  4. Select a JRE version greater than JRE 1.6.0.x
Caution   Composer and AI Enabler are only available for 32-bit platforms.
Note   For Composer 3.8.0 SP13 the client can be run using Jre8

Related Links